Supported Versions

Java Compatibility

Each release of Apache Flink® supports one or more Java Versions.

Apache Flink® Version Java Version
1.4 1.8
1.5 1.8
1.6 1.8
1.7 1.8
1.8 1.8